Home >Supported Browsers

Supported Browsers

Compass will work with a number of popular browsers such as Internet Explorer, Firefox, and Safari. Browsers are frequently updated and their feature sets change.

It is important for you to decide which browser to use based upon your interactions with the Compass system. Based upon testing, the following browsers are recommended for Emory users:

  • If you use Windows and only access Compass through the Web we recommend:
    • Internet Explorer 7.0
    • Firefox 3.5.1
  • If you use Windows and you plan to use Excel upload/download features we recommend:
    • Firefox 3.5.1

If you use a Mac, we recommend Firefox 3.5.1. NOTE: The add-in for drill down capability does not work for nVision with MS Excel in the Mac Version because MS Excel does not support Visual Basic add-ins for the Mac.